Strategic Insights Degraded Performance

Incident Report for Legion

Resolved

This incident has been resolved.
Posted Feb 03, 2026 - 09:13 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Feb 02, 2026 - 08:01 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Feb 01, 2026 - 07:34 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 31, 2026 - 18:35 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 31, 2026 - 08:14 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 30, 2026 - 14:46 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 30, 2026 - 04:59 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 29, 2026 - 21:14 PST

Update

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 29, 2026 - 15:37 PST

Identified

The issue has been identified and a fix is being implemented. Further updates will be provided as resolution progresses.
Posted Jan 29, 2026 - 11:14 PST

Investigating

We are currently experiencing data replication delays in the Strategic Insights application. Our team is working to restore normal service levels. We apologize for any inconvenience
Posted Jan 29, 2026 - 07:51 PST
This incident affected: Production (US Production).