Early Access Emergency Maintenance

Incident Report for Legion

Resolved

The US Early Access emergency maintenance has been completed.
Posted Dec 08, 2025 - 10:18 PST

Update

We are continuing to work on restoring the application. We expect work to be completed by 10:30 PST
Posted Dec 08, 2025 - 09:34 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 08, 2025 - 08:47 PST

Investigating

We are currently performing emergency maintenance on our US Early Access environment. Our team is working to restore the application and will provide hourly updates until the issue is resolved.

We apologize for any inconvenience.
Posted Dec 08, 2025 - 08:40 PST
This incident affected: Early Access (US Early Access).